转载  centos python升级3.x后pip3 install 出现pip is configured with locations that require TLS/SSL,

分类:发现 2019-06-09T12:08:27    12人阅读   

1.解決办法,首先安装 openssl-devel


sudo yum install openssl-devel

安装成功后,使用pip3 继续安装

#如果还是报错,那么进入步骤2

2.那么你需要 进入python 安装包 目录下重新编译并且安装python

cd Python-3.6.3

进入目录下,依次执行以下3条命令

./configure --with-ssl

make

sudo make install

执行完成后 pip3 就可以安装軟件了
---------------------


分享到: