转载 

node node-sass sass-loader版本对应问题

分类:    271人阅读    IT小君  2024-03-24 16:30

1.查看本地node版本

node -v

具体对应版本如下图:

具体对应链接地址:

node-sass

2.查看项目中package中node-sass和sass-loader是否对应node版本

3.不对应应修改成对应版本号

以下是部分版本号对应,具体可百度

sass-loader 4.1.1,node-sass 4.3.0

sass-loader 7.0.3,node-sass 4.7.2

sass-loader 7.3.1,node-sass 4.7.2

sass-loader 7.3.1,node-sass 4.14.1

sass-loader 10.0.1,node-sass 6.0.1

4.如果node是最新版本,则可以直接使用以下命令安装即可

npm install sass-loader node-sass --save-dev

cnpm install sass-loader node-sass --save-dev

5.如果node不是最新版本,则需要安装对应的版本号才行

npm install sass-loader@版本号 node-sass@版本号 --save-dev //安装对应的版本

cnpm install sass-loader@版本号 node-sass@版本号 --save-dev //安装对应的版本

转载于:https://zhuanlan.zhihu.com/p/479888799

支付宝打赏 微信打赏

如果文章对你有帮助,欢迎点击上方按钮打赏作者

 工具推荐 更多»